DatabaseRestoreForwardingXrefSymbols
Method
|
This method must be used with
RestoreOriginalXrefSymbols() and should be wrapped around all code
with plans to edit and/or save external reference databases.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void RestoreForwardingXrefSymbols()
Public Sub RestoreForwardingXrefSymbols
public:
void RestoreForwardingXrefSymbols()
member RestoreForwardingXrefSymbols : unit -> unit
Remarks
RestoreForwardingXrefSymbols() redoes all the changes back to a
proper external reference resolve status. If the original symbols
are restored and then changes are made to the symbols before
RestoreForwardingXrefSymbols(), those changes will be overwritten.
However, newly added symbols are properly resolved during
RestoreForwardingXrefSymbols(), and then are included in the
undo/redo of future calls to these two methods. (The only
workaround for wanting to change the symbols themselves is to go
ahead and make the changes, save them to disk, and then let
RestoreForwardingXrefSymbols() overwrite the changes. When all is
done, reload the external reference from disk.) The symbols
affected are the table and records for blocks, layers, linetypes,
text styles, dimension styles, registered applications, and plot
styles, as well as any custom object changes made during and
between the XrefBeginAttached and XrefBeginOtherAttached events. To
properly resolve the external reference,
RestoreForwardingXrefSymbols() needs write access to the symbol
tables and symbol table records in the host drawing. Therefore,
applications should close any open symbol tables or symbol table
records before calling RestoreForwardingXrefSymbols().
See Also