Polyline2dInsertVertexAt(ObjectId,
Vertex2d) Method
|
Inserts the specified vertex entity to this
polyline entity after the specified vertex, and makes this polyline
its owner.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public ObjectId InsertVertexAt(
ObjectId vertexId,
Vertex2d newVertex
)
Public Function InsertVertexAt (
vertexId As ObjectId,
newVertex As Vertex2d
) As ObjectId
public:
ObjectId InsertVertexAt(
ObjectId vertexId,
Vertex2d^ newVertex
)
member InsertVertexAt :
vertexId : ObjectId *
newVertex : Vertex2d -> ObjectId
Parameters
- vertexId ObjectId
- [in] Object ID of the vertex after which to insert the
specified vertex.
- newVertex Vertex2d
- [in] Vertex to insert.
Return Value
ObjectId
Returns the object ID of the newly inserted vertex.
Remarks
The vertex is made
database-resident. If this polyline entity is not
database-resident, the vertex is made database-resident when the
polyline is made database-resident. To insert the specified vertex
at the start of this polyline, use a nullptr for vertexId.
See Also