LayerStateManagerGetLayerStateLayers Method

Retrieves a list of names of layers associated with a specified layer state.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public ArrayList GetLayerStateLayers(
        string name,
        bool bInvert
)

Parameters

name  String
[in] Name of the layer state to get the list of layer names for.
bInvert  Boolean
[in] Flag specifying whether to return an inverted list.

Return Value

ArrayList
Remarks
If the bInvert parameter is true, an inverted list is returned, i.e. a list of layer names in the current database that are not associated with a specified layer state.
See Also

©  Bricsys NV. All rights reserved.