SymbolUtilityServicesGetSymbolNameFromPathName Method

Retrieves a suitable symbol name from a path name. The symbol name represents the filename component of the path. Any of the specified filename extensions are removed. If an invalid pathName is provided, the symbol name can also be invalid.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public static string GetSymbolNameFromPathName(
        string pathName,
        string extensions
)

Parameters

pathName  String
 
extensions  String
[in] List of extensions for which symbol names are searched.

Return Value

String
Block name.
Remarks
The extensions must be separated by semicolons and should not have dots before extension names, for example: "dwg;dxf".
See Also

©  Bricsys NV. All rights reserved.