PolylineOnSegmentAt Method

Checks whether the specified OCS point is on the specified segment of this polyline entity, and retrieves the parameter of that point on the segment.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual bool OnSegmentAt(
        int index,
        Point2d pt2d,
        double value
)

Parameters

index  Int32
[in] Segment index.
pt2d  Point2d
[in] The OCS point to query.
value  Double
[out] Receives the parameter at that point.

Return Value

Boolean
true if the specified OCS point is on the specified segment, false otherwise.
Remarks
The returned parameter is in the parametric form of the segment (linear or arc).
See Also

©  Bricsys NV. All rights reserved.