PolylineCurve3d(KnotCollection,
Point3dCollection) Constructor
|
Constructor for the PolylineCurve3d class.
Creates a polyline with the specified knots and point values.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public PolylineCurve3d(
KnotCollection knots,
Point3dCollection controlPoints
)
Public Sub New (
knots As KnotCollection,
controlPoints As Point3dCollection
)
public:
PolylineCurve3d(
KnotCollection^ knots,
Point3dCollection^ controlPoints
)
new :
knots : KnotCollection *
controlPoints : Point3dCollection -> PolylineCurve3d
Parameters
- knots KnotCollection
- [in] Knot vector.
- controlPoints Point3dCollection
- [in] Array of 3D points with which a polyline is
constructed.
See Also