SurfaceChamferEdges Method
|
Creates associative chamfers at the specified
edges of the surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void ChamferEdges(
SubentityId[] subentityIds,
SubentityId baseSubentityId,
double baseDist,
double otherDist
)
Public Overridable Sub ChamferEdges (
subentityIds As SubentityId(),
baseSubentityId As SubentityId,
baseDist As Double,
otherDist As Double
)
public:
virtual void ChamferEdges(
array<SubentityId>^ subentityIds,
SubentityId baseSubentityId,
double baseDist,
double otherDist
)
abstract ChamferEdges :
subentityIds : SubentityId[] *
baseSubentityId : SubentityId *
baseDist : float *
otherDist : float -> unit
override ChamferEdges :
subentityIds : SubentityId[] *
baseSubentityId : SubentityId *
baseDist : float *
otherDist : float -> unit
Parameters
- subentityIds SubentityId
- [in] Object IDs of the edges at which the chamfer is
applied.
- baseSubentityId SubentityId
- [in] Object ID of the base face where the chamfer is
applied.
- baseDist Double
- [in] Chamfer distance on the base face.
- otherDist Double
- [in] Chamfer distance on the other faces.
Remarks
This method is
implemented only for the Spatial modeler.
See Also