SurfaceCreateExtendSurface Method
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static ObjectId CreateExtendSurface(
ObjectId sourceSurface,
SubentityId[] edges,
double extension,
EdgeExtensionType extOption,
bool associativeEnabled
)
Public Shared Function CreateExtendSurface (
sourceSurface As ObjectId,
edges As SubentityId(),
extension As Double,
extOption As EdgeExtensionType,
associativeEnabled As Boolean
) As ObjectId
public:
static ObjectId CreateExtendSurface(
ObjectId sourceSurface,
array<SubentityId>^ edges,
double extension,
EdgeExtensionType extOption,
bool associativeEnabled
)
static member CreateExtendSurface :
sourceSurface : ObjectId *
edges : SubentityId[] *
extension : float *
extOption : EdgeExtensionType *
associativeEnabled : bool -> ObjectId
Parameters
- sourceSurface ObjectId
-
- edges SubentityId
-
- extension Double
-
- extOption EdgeExtensionType
-
- associativeEnabled Boolean
-
Return Value
ObjectId
See Also