NurbSurfaceInsertControlPointsAtU
Method
|
Inserts a row of control points at the
specified u-knot parameter.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void InsertControlPointsAtU(
double dU,
Point3dCollection vCtrlPts,
DoubleCollection vWeights
)
Public Sub InsertControlPointsAtU (
dU As Double,
vCtrlPts As Point3dCollection,
vWeights As DoubleCollection
)
public:
void InsertControlPointsAtU(
double dU,
Point3dCollection^ vCtrlPts,
DoubleCollection^ vWeights
)
member InsertControlPointsAtU :
dU : float *
vCtrlPts : Point3dCollection *
vWeights : DoubleCollection -> unit
Parameters
- dU Double
- [in] U parameter.
- vCtrlPts Point3dCollection
- [in] An array of control points to add.
- vWeights DoubleCollection
- [in] Array of weight values to add if the surface is
rational.
Remarks
If the surface
doesn't contain any NURBS information, the method throws the
eFail exception. If the dU parameter is out of range, throws the eOutOfRange exception.
See Also