Vector3dAngleOnPlane Method

Returns the angle of this vector projected onto the specified plane.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public double AngleOnPlane(
        PlanarEntity plane
)

Parameters

plane  PlanarEntity
[in] Any 3D plane.

Return Value

Double
A new vector that is the result of this vector + the passed vector.
Remarks
This vector is projected orthogonally onto the plane through its origin and is measured with respect to axis1 as returned by plane.getCoordSystem(origin, axis1, axis2).
See Also

©  Bricsys NV. All rights reserved.