NurbCurve2d(Point2dCollection,
Vector2dCollection, Boolean) Constructor
|
Constructor for the NurbCurve2d class.
Constructs a 2D polynomial curve interpolating a given array of 2D
points.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public NurbCurve2d(
Point2dCollection fitPoints,
Vector2dCollection fitTangents,
bool periodic
)
Public Sub New (
fitPoints As Point2dCollection,
fitTangents As Vector2dCollection,
periodic As Boolean
)
public:
NurbCurve2d(
Point2dCollection^ fitPoints,
Vector2dCollection^ fitTangents,
bool periodic
)
new :
fitPoints : Point2dCollection *
fitTangents : Vector2dCollection *
periodic : bool -> NurbCurve2d
Parameters
- fitPoints Point2dCollection
- [in] Array of 2D points through which to fit the curve.
- fitTangents Vector2dCollection
- [in] Vectors interpolating the curve's derivatives at the fit
points.
- periodic Boolean
- [in] Flag that specifies whether to make the curve periodic (a
closed curve).
Remarks
If isPeriodic =
true, the first and last fitPoints must be identical. The same must
be true for fitTangents.
See Also