NurbCurve2d Class

This class represents non-uniform rational B-splines (NURBS) in 2D space. For more information, see Working with NURBS Curves.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryCurve2d
          Teigha.GeometrySplineEntity2d
            Teigha.GeometryNurbCurve2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class NurbCurve2d : SplineEntity2d

The NurbCurve2d type exposes the following members.

Constructors
  Name Description
Public method NurbCurve2d Default constructor for the NurbCurve2d class. With this constructor no actual data is stored in the object.
Public method NurbCurve2d(EllipticalArc2d) Constructor for the NurbCurve2d class. Constructs a 2D curve from a passed 2D elliptical arc.
Public method NurbCurve2d(LineSegment2d) Constructor for the NurbCurve2d class. Constructs a 2D curve from a passed 2D line segment.
Public method NurbCurve2d(Point2dCollection) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points.
Public method NurbCurve2d(Point2dCollection, Tolerance) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points within a given tolerance.
Public method NurbCurve2d(Int32, PolylineCurve2d, Boolean) Constructor for the NurbCurve2d class. Constructs a NURBS curve with a specified degree value, fit polyline, and a flag specifying whether to make a closed curve.
Public method NurbCurve2d(Point2dCollection, Vector2dCollection, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D polynomial curve interpolating a given array of 2D points.
Public method NurbCurve2d(Int32, KnotCollection, Point2dCollection, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D curve according to the passed parameters.
Public method NurbCurve2d(Point2dCollection, Vector2dCollection, Tolerance, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D polynomial curve interpolating a given array of 2D points according to the specified tolerance.
Public method NurbCurve2d(Int32, KnotCollection, Point2dCollection, DoubleCollection, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D curve according to the passed parameters.
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points and using given derivatives at the start point and endpoint.
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points, knot parameterization, and using given derivatives at the start point and endpoint.
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, Tolerance) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points according to the specified tolerance and using given derivatives at the start point and endpoint.
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum, Tolerance) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points, knot parameterization, and using given derivatives at the start point and endpoint.
Top
Properties
  Name Description
Public property DefinitionData  
Public property EvalMode  
Public property FitData  
Public property FitKnotParameterization  
Public property FitTolerance  
Public property NumFitPoints  
Public property NumWeights  
Top
Methods
  Name Description
Public method AddControlPointAt Adds a control point at the specified knot.
Public method AddFitPointAt Inserts a fit point at the specified index.
Public method AddKnot Adds a new knot to the spline knot array.
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method DeleteControlPointAt Deletes a control point at the specified index.
Public method DeleteFitPointAt Removes a fit point with the specified index.
Public method ElevateDegree Increases the spline degree by the specified value.
Public method GetFitPointAt Retrieves the fit point at the specified index.
Public method GetFitTangents Retrieves the start and end tangents if this spline was constructed with fit data.
Public method GetParametersOfC1Discontinuity Returns parameter values of all points on the spline where the tangent vector is not continuous. The returned array contains points where the tangent vector to the left of the point is not equal to the tangent vector to the right of the point.
Public method GetParametersOfC1Discontinuity(Tolerance) Returns parameter values of all points on the spline where the tangent vector is not continuous according to the specified tolerance. The returned array contains points where the tangent vector to the left of the point is not equal to the tangent vector to the right of the point.
Public method GetParametersOfG1Discontinuity Returns parameter values of all points on the spline where the tangent vector is not continuous. The returned array contains points where the tangent vector to the left of the point does not have the same direction as the tangent vector to the right of the point.
Public method GetParametersOfG1Discontinuity(Tolerance) Returns parameter values of all points on the spline where the tangent vector is not continuous according to the specified tolerance. The returned array contains points where the tangent vector to the left of the point does not have the same direction as the tangent vector to the right of the point.
Public method GetWeightAt Returns the weight at the specified index.
Public method HardTrimByParams Trims this NURBS curve by the new start and end parameters.
Public method InsertKnot Inserts a new knot to the spline knot array.
Public method JoinWith Joins the specified OdGeNurbCurve2d with this spline and returns a reference to the recomputed spline.
Public method MakeClosed Makes an open spline closed, and returns a reference to this spline.
Public method MakeNonPeriodic Makes this spline non-periodic (if it is not).
Public method MakeOpen Makes a closed spline open.
Public method MakePeriodic Makes this spline periodic (if it is not).
Public method MakeRational Makes this spline rational (if it is not).
Public method PurgeFitData Purges the fit data that defines this spline. The fit data consists of fit points, fit tolerance, start tangent, and end tangent. The definition of the spline is unchanged.
Public method SetEvaluateMode Sets the evaluation mode.
Public method SetFitData(Int32, Point2dCollection) Sets the fit data for this spline.
Public method SetFitData(Int32, Point2dCollection, Tolerance) Sets the fit data for this spline.
Public method SetFitData(Point2dCollection, Vector2d, Vector2d) Sets the fit data for this spline.
Public method SetFitData(Point2dCollection, Vector2d, Vector2d, Tolerance) Sets the fit data for this spline.
Public method SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Boolean) Sets the fit data for this spline.
Public method SetFitData(Point2dCollection, Vector2d, Vector2d, KnotParameterizationEnum, Tolerance) Sets the fit data for this spline.
Public method SetFitData(KnotCollection, Point2dCollection, Vector2d, Vector2d, Tolerance, Boolean) Sets the fit data for this spline.
Public method SetFitPointAt Sets the fit point at the specified index.
Public method SetFitTangents Sets the fit tangents for this spline.
Public method SetWeightAt Sets the weight at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.