NurbCurve2d Constructor

Overload List
  Name Description
Public method NurbCurve2d Default constructor for the NurbCurve2d class. With this constructor no actual data is stored in the object.
Public method NurbCurve2d(EllipticalArc2d) Constructor for the NurbCurve2d class. Constructs a 2D curve from a passed 2D elliptical arc.
Public method NurbCurve2d(LineSegment2d) Constructor for the NurbCurve2d class. Constructs a 2D curve from a passed 2D line segment.
Public method NurbCurve2d(Point2dCollection) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points.
Public method NurbCurve2d(Point2dCollection, Tolerance) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points within a given tolerance.
Public method NurbCurve2d(Int32, PolylineCurve2d, Boolean) Constructor for the NurbCurve2d class. Constructs a NURBS curve with a specified degree value, fit polyline, and a flag specifying whether to make a closed curve.
Public method NurbCurve2d(Point2dCollection, Vector2dCollection, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D polynomial curve interpolating a given array of 2D points.
Public method NurbCurve2d(Int32, KnotCollection, Point2dCollection, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D curve according to the passed parameters.
Public method NurbCurve2d(Point2dCollection, Vector2dCollection, Tolerance, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D polynomial curve interpolating a given array of 2D points according to the specified tolerance.
Public method NurbCurve2d(Int32, KnotCollection, Point2dCollection, DoubleCollection, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D curve according to the passed parameters.
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points and using given derivatives at the start point and endpoint.
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points, knot parameterization, and using given derivatives at the start point and endpoint.
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, Tolerance) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points according to the specified tolerance and using given derivatives at the start point and endpoint.
Public method NurbCurve2d(Point2dCollection, Vector2d, Vector2d, Boolean, Boolean, KnotParameterizationEnum, Tolerance) Constructor for the NurbCurve2d class. Constructs a 2D curve interpolating a given array of 2D points, knot parameterization, and using given derivatives at the start point and endpoint.
Top
See Also