SurfaceSurfaceIntersectorGetIntersectionConfigurations
Method
|
Retrieves the surface configurations on either
side of the intersection. Currently not implemented.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public SurfaceSurfaceIntersectorConfigurations GetIntersectionConfigurations(
int number
)
Public Function GetIntersectionConfigurations (
number As Integer
) As SurfaceSurfaceIntersectorConfigurations
public:
SurfaceSurfaceIntersectorConfigurations GetIntersectionConfigurations(
int number
)
member GetIntersectionConfigurations :
number : int -> SurfaceSurfaceIntersectorConfigurations
Parameters
- number Int32
- [in] The zero-based index of the intersection.
Return Value
SurfaceSurfaceIntersectorConfigurations
The SurfaceSurfaceIntersectorConfigurations structure that stores
information about: * Intersector dimension. * Intersector type. *
Configuration for surface 1 on the left side of the intersection. *
Configuration for surface 1 on the right side of the intersection.
* Configuration for surface 2 on the left side of the intersection.
* Configuration for surface 2 on the right side of the
intersection.
Remarks
This method throws
one of the following exceptions if the method fails: *
kXXIndexOutOfRange - Index out of range. * kXXUnknown - Intersector
is not initialized.
See Also