EntityColor(ColorMethod, Int16)
Constructor
|
Creates a new instance of EntityColor using
color method and color index.
Namespace: Teigha.Colors
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public EntityColor(
ColorMethod value,
short index
)
Public Sub New (
value As ColorMethod,
index As Short
)
public:
EntityColor(
ColorMethod value,
short index
)
new :
value : ColorMethod *
index : int16 -> EntityColor
Parameters
- value ColorMethod
- Color method.
- index Int16
- Color index (ACI).
Remarks
index must be one of the following:
Value |
Description |
0 |
ByBlock |
7 |
Foreground color |
256 |
ByLayer |
1 |
Red |
2 |
Yellow |
3 |
Green |
4 |
Cyan |
5 |
Blue |
6 |
Magenta |
8-255 |
Defined by display device |
257 |
No color |
See Also