EntityColor Structure

Wraps OdCmEntityColor class. Implements EntityColor objects, which represent the colors of OdDbEntity objects
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.ColorsEntityColor

Namespace: Teigha.Colors
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct EntityColor

The EntityColor type exposes the following members.

Constructors
  Name Description
Public method EntityColor(ColorMethod) Creates a new instance of EntityColor using color method.
Public method EntityColor(Int32) Creates a new instance of EntityColor using color value.
Public method EntityColor(ColorMethod, Int16) Creates a new instance of EntityColor using color method and color index.
Public method EntityColor(Byte, Byte, Byte) Creates a new instance of EntityColor using R, G, B color values
Top
Properties
  Name Description
Public property Blue Gets the blue component for this EntityColor object.
Public property ColorIndex Gets the color index (ACI) for this EntityColor object.
Public property ColorMethod Gets the color method for this EntityColor object.
Public property Green Gets the green component for this EntityColor object.
Public property IsByAci Gets if the color method for this object is ColorMethod.ByAci.
Public property IsByBlock Gets if the color method for this object is ColorMethod.ByBlock or the color method is ColorMethod.ByAci and the ACI is ByBlock.
Public property IsByColor Gets if the color method for this object is ColorMethod.ByColor.
Public property IsByLayer Gets if the color method for this object is ColorMethod.ByLayer or the color method is ColorMethod.ByAci and the ACI is ByLayer.
Public property IsByPen Currently not implemented.
Public property IsForeground Gets if the color is foreground color or the color method is ColorMethod.ByAci and the ACI is Foreground.
Public property IsLayerFrozen Currently not implemented.
Public property IsLayerFrozenOrOff Currently not implemented.
Public property IsLayerOff Currently not implemented.
Public property IsNone Gets if there is no color.
Public property LayerIndex Currently not implemented.
Public property PenIndex Currently not implemented.
Public property Red Gets the red component for this EntityColor object.
Public property TrueColor Gets Returns the TrueColor value of this EntityColor object.
Top
Methods
  Name Description
Public methodStatic member LookUpAci Returns the color index (ACI) corresponding to the specified red, green, and blue components.
Public methodStatic member LookUpRgb Returns the RGB color value and the color method corresponding to the specified color index (ACI).
Top
See Also

©  Bricsys NV. All rights reserved.