ViewDolly(Vector3d) Method
|
Translates the camera position and target by
the specified camera coordinate dolly amount.
Namespace: Teigha.GraphicsSystem
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void Dolly(
Vector3d dollyVector
)
Public Overridable Sub Dolly (
dollyVector As Vector3d
)
public:
virtual void Dolly(
Vector3d dollyVector
)
abstract Dolly :
dollyVector : Vector3d -> unit
override Dolly :
dollyVector : Vector3d -> unit
Parameters
- dollyVector Vector3d
- [in] Camera coordinate dolly vector.
Remarks
Camera coordinates
are relative to the view of a target from a camera. * The Y-axis is
along the up vector. * The Z-axis is along the vector from the
camera position to the target. * The X-axis is the cross product of
the Y-axis and the Z-axis.
See Also