SubDMeshSetCrease(FullSubentityPath, Double) Method
|
Sharpens faces, edges, and vertices of a
mesh.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetCrease(
FullSubentityPath[] subentPaths,
double creaseVal
)
Public Sub SetCrease (
subentPaths As FullSubentityPath(),
creaseVal As Double
)
public:
void SetCrease(
array<FullSubentityPath>^ subentPaths,
double creaseVal
)
member SetCrease :
subentPaths : FullSubentityPath[] *
creaseVal : float -> unit
Parameters
- subentPaths FullSubentityPath
- [in] Array of subentities to which the crease is applied.
- creaseVal Double
- [in] Flag that indicates when to apply the crease.
Remarks
The value of the
creaseVal parameter can be one of the following:
ValueDescription-1 Always apply the crease. 0 Never
apply the crease. any positive value Apply the crease starting from
this level.
See Also