Polyline2dInsertVertexAt(Vertex2d,
Vertex2d) Method
|
Inserts the specified vertex entity into this
polyline entity after the specified vertex, and makes this Polyline
its owner.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void InsertVertexAt(
Vertex2d indexVertex,
Vertex2d newVertex
)
Public Sub InsertVertexAt (
indexVertex As Vertex2d,
newVertex As Vertex2d
)
public:
void InsertVertexAt(
Vertex2d^ indexVertex,
Vertex2d^ newVertex
)
member InsertVertexAt :
indexVertex : Vertex2d *
newVertex : Vertex2d -> unit
Parameters
- indexVertex Vertex2d
-
- newVertex Vertex2d
- [in] Vertex to insert.
Remarks
The vertex is made
database-resident. If this polyline entity is not
database-resident, the vertex is made database-resident when the
polyline is made database-resident. To insert the specified vertex
at the start of this polyline, use a nullptr for vertexId.
See Also