SectionGenerateSectionGeometry Method

Generates section geometry.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void GenerateSectionGeometry(
        Entity pEnt,
        out Array pIntFillEnts,
        out Array pBackgroundEnts,
        out Array pForegroundEnts,
        out Array pFurveTangencyEnts,
        out Array pCurveTangencyEnts
)

Parameters

pEnt  Entity
[in] Sectionable entity.
pIntFillEnts  Array
[out] Receives intersection boundary entities.
pBackgroundEnts  Array
[out] Receives intersection fill annotation entities.
pForegroundEnts  Array
[out] Receives background entities.
pFurveTangencyEnts  Array
[out] Receives foreground entities.
pCurveTangencyEnts  Array
[out] Receives curve tangency entities.
See Also

©  Bricsys NV. All rights reserved.