LinkedTableDataUpdateDataLink(Int32,
Int32, UpdateDirection, UpdateOption)
Method
|
Updates the data link of a cell.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void UpdateDataLink(
int row,
int column,
UpdateDirection dir,
UpdateOption option
)
Public Overridable Sub UpdateDataLink (
row As Integer,
column As Integer,
dir As UpdateDirection,
option As UpdateOption
)
public:
virtual void UpdateDataLink(
int row,
int column,
UpdateDirection dir,
UpdateOption option
)
abstract UpdateDataLink :
row : int *
column : int *
dir : UpdateDirection *
option : UpdateOption -> unit
override UpdateDataLink :
row : int *
column : int *
dir : UpdateDirection *
option : UpdateOption -> unit
Parameters
- row Int32
- [in] Row index of the cell.
- column Int32
- [in] Column index of the cell.
- dir UpdateDirection
- [in] Direction of update.
- option UpdateOption
- [in] Update option.
Remarks
The method
generates the eInvalidInput exception
when the input row number and column number are less than 0 or
greater than the table size. Direction can take one of the
following values: NameValueSourceToData 0x1 DataToSource 0x2 Update option
should take one of the following values: NameValueNone 0 SkipFormat
0x20000 UpdateRowHeight 0x40000 UpdateColumnWidth 0x80000
AllowSourceUpdate 0x100000 ForceFullSourceUpdate 0x200000
OverwriteContentModifiedAfterUpdate 0x400000
OverwriteFormatModifiedAfterUpdate 0x800000 ForPreview 0x1000000
IncludeXrefs 0x2000000
See Also