MPolygonInsertMPolygonLoopAt
Method
|
Inserts a polygon loop to the specified
position.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void InsertMPolygonLoopAt(
int loopIndex,
BulgeVertexCollection bulgeVertexCol,
bool excludeCrossing,
double tolerance
)
Public Overridable Sub InsertMPolygonLoopAt (
loopIndex As Integer,
bulgeVertexCol As BulgeVertexCollection,
excludeCrossing As Boolean,
tolerance As Double
)
public:
virtual void InsertMPolygonLoopAt(
int loopIndex,
BulgeVertexCollection^ bulgeVertexCol,
bool excludeCrossing,
double tolerance
)
abstract InsertMPolygonLoopAt :
loopIndex : int *
bulgeVertexCol : BulgeVertexCollection *
excludeCrossing : bool *
tolerance : float -> unit
override InsertMPolygonLoopAt :
loopIndex : int *
bulgeVertexCol : BulgeVertexCollection *
excludeCrossing : bool *
tolerance : float -> unit
Parameters
- loopIndex Int32
-
- bulgeVertexCol BulgeVertexCollection
- [in] Collection of bulge values for corresponding 2D
vertices.
- excludeCrossing Boolean
- [in] Flag that specifies whether to disable creating a polygon
if there are crosses between loops.
- tolerance Double
- [in] Measurement accuracy tolerance.
See Also