BulgeVertexCollection Class

This class represents a collection of BulgeVertex objects.
Inheritance Hierarchy
SystemObject
  System.CollectionsCollectionBase
    Teigha.DatabaseServicesBulgeVertexCollection

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class BulgeVertexCollection : CollectionBase

The BulgeVertexCollection type exposes the following members.

Constructors
  Name Description
Public method BulgeVertexCollection Default constructor for the BulgeVertexCollection class.
Top
Properties
  Name Description
Public property Item Property that represents a bulge vertex at the specified index.
Top
Methods
  Name Description
Public method Add Adds a BulgeVertex object to the collection.
Public method Contains Checks whether this collection contains a bulge vertex that matches the specified bulge vertex.
Public method CopyTo Copies this bulge vertex collection to the specified array at the specified index.
Public method IndexOf Returns the index of the bulge vertex in this collection that matches the specified bulge vertex.
Public method Insert Inserts the specified bulge vertex to the collection at the provided index.
Protected method OnValidate
(Overrides CollectionBaseOnValidate(Object))
Public method Remove Removes a bulge vertex that matches the specified bulge vertex from the collection.
Top
See Also

©  Bricsys NV. All rights reserved.