NurbCurve2dSetFitData(Point2dCollection, Vector2d, Vector2d) Method

Sets the fit data for this spline.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void SetFitData(
        Point2dCollection fitPoints,
        Vector2d startTangent,
        Vector2d endTangent
)

Parameters

fitPoints  Point2dCollection
[in] Interpolation points.
startTangent  Vector2d
[in] Start tangent.
endTangent  Vector2d
[in] End tangent.
Remarks
Recomputes the spline from the input fit points and start and end tangents.
See Also

©  Bricsys NV. All rights reserved.