LeaderAppendVertex Method
|
Appends the specified WCS vertex to this
leader entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual bool AppendVertex(
Point3d pointToAdd
)
Public Overridable Function AppendVertex (
pointToAdd As Point3d
) As Boolean
public:
virtual bool AppendVertex(
Point3d pointToAdd
)
abstract AppendVertex :
pointToAdd : Point3d -> bool
override AppendVertex :
pointToAdd : Point3d -> bool
Parameters
- pointToAdd Point3d
- [in] Vertex to append.
Return Value
Boolean
Returns
true if the vertex is
successfully appended,
false
otherwise.
Remarks
The specified
vertex is projected onto the plane of this leader, parallel to its
normal. If the specified vertex is inside a 2e-10 cube surrounding
the previous vertex, it is not appended.
See Also