LinkedTableDataSetValue(Int32, Int32,
Int32, Object, ParseOption) Method
|
Sets a value to the specified content of a
cell.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetValue(
int row,
int column,
int content,
Object value,
ParseOption parseOption
)
Public Overridable Sub SetValue (
row As Integer,
column As Integer,
content As Integer,
value As Object,
parseOption As ParseOption
)
public:
virtual void SetValue(
int row,
int column,
int content,
Object^ value,
ParseOption parseOption
)
abstract SetValue :
row : int *
column : int *
content : int *
value : Object *
parseOption : ParseOption -> unit
override SetValue :
row : int *
column : int *
content : int *
value : Object *
parseOption : ParseOption -> unit
Parameters
- row Int32
- [in] Row index of the cell.
- column Int32
- [in] Column index of the cell.
- content Int32
- [in] Number of the content.
- value Object
- [in] Value to set.
- parseOption ParseOption
- [in] Parse option of the value.
Remarks
The method
generates the eInvalidInput exception
when the input row number and column number are less than 0 or
greater than the table size. The method generates the eIsWriteProtected exception when content is not
editable. Parse option is an enumerator and takes one of the
following values: NameValueParseOptionNone 0x00 SetDefaultFormat 0x01
PreserveMtextFormat 0x02
See Also