Solid3dExtrudeFaces Method

Extrudes faces of the solid with the specified distance and taper angle.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public virtual void ExtrudeFaces(
        SubentityId[] subentityIds,
        double height,
        double taper
)

Parameters

subentityIds  SubentityId
[in] Face's subentity ID in the solid.
height  Double
[in] Height of extrusion.
taper  Double
[in] Taper angle in radians in the range [-OdaPI/2..OdaPI/2].
Remarks
The distance of extrusion is determined by the height parameter and the taper angle. The extrusion direction can be along or opposite the normal of each extruded face depending on the height value: * If the height is positive, the direction is along the normal (extruding faces outward from the solid). * If the height is negative, the direction is opposite to the normal (extruding faces into the solid). The following constraints are applied: * Number of specified faces (in the subentityIds parameter) must be more than zero. * |height| >= 1e-6 * |taper| >= (OdaPI/2) - 1e-6 This method is implemented only for the Spatial modeler.
See Also

©  Bricsys NV. All rights reserved.