CircularArc2d(Point2d, Point2d, Double, Boolean) Constructor

Constructor for the CircularArc2d class. Creates an arc according to the specified parameters.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public CircularArc2d(
        Point2d startPoint,
        Point2d endPoint,
        double bulge,
        bool bulgeFlag
)

Parameters

startPoint  Point2d
[in] Start point of an arc.
endPoint  Point2d
[in] End point of an arc.
bulge  Double
[in] Bulge distance.
bulgeFlag  Boolean
[in] Specifies how to calculate arc parameters according to the bulge distance.
Remarks
If a line between the startPoint and endPoint is drawn, the distance between this line and the midpoint of the arc is equal to the length of the bulge. If bulgeFlag is true, the bulge is interpreted as the maximum distance between the two input points between the arc and the chord. If bulgeFlag is false, the bulge is interpreted as the tangent of 1/4 of the included angle (tan(ang/4)), where ang is the angle of the arc segment between the two input points. The arc is constructed in counterclockwise direction. This constructor always creates an arc and cannot be used to construct a circle.
See Also

©  Bricsys NV. All rights reserved.