CircularArc2d Class

This .NET class wraps the OdGeCircArc2d class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity2d
        Teigha.GeometryCurve2d
          Teigha.GeometryCircularArc2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class CircularArc2d : Curve2d

The CircularArc2d type exposes the following members.

Constructors
  Name Description
Public method CircularArc2d Default constructor for the CircularArc2d class. Constructs a 2D circle with a center of (0,0) and a radius of 1.
Public method CircularArc2d(Point2d, Double) Constructor for the CircularArc2d class. Creates a circle with the specified center and radius.
Public method CircularArc2d(Point2d, Point2d, Point2d) Constructor for the CircularArc2d class. Creates an arc with the specified three points.
Public method CircularArc2d(Point2d, Point2d, Double, Boolean) Constructor for the CircularArc2d class. Creates an arc according to the specified parameters.
Public method CircularArc2d(Point2d, Double, Double, Double, Vector2d, Boolean) Constructor for the CircularArc2d class.
Top
Properties
  Name Description
Public property Center  
Public property EndAngle  
Public property EndPoint  
Public property IsClockWise  
Public property Radius  
Public property ReferenceVector  
Public property StartAngle  
Public property StartPoint  
Top
Methods
  Name Description
Public methodStatic member Create Creates a CircularArc2d object based on the passed pointer.
Public method GetTangent(Point2d) Retrieves the tangent line at the specified point.
Public method GetTangent(Point2d, Tolerance) Retrieves the tangent line at the specified point according to the specified tolerance.
Public method IntersectWith(CircularArc2d) Retrieves the intersection points between this circular arc and the passed circular arc.
Public method IntersectWith(LinearEntity2d) Retrieves the intersection points between this circular arc and the passed line.
Public method IntersectWith(CircularArc2d, Tolerance) Retrieves the intersection points between this circular arc and the passed circular arc according to the specified tolerance.
Public method IntersectWith(LinearEntity2d, Tolerance) Retrieves the intersection points between this circular arc and the passed line according to the specified tolerance.
Public method IsInside(Point2d) Checks whether the specified point is inside the full circle of this arc.
Public method IsInside(Point2d, Tolerance) Checks whether the specified point is inside the full circle of this arc within the specified tolerance.
Public method Set(Point2d, Double)  
Public method Set(Point2d, Point2d, Point2d)  
Public method Set(Point2d, Point2d, Double, Boolean)  
Public method Set(Curve2d, Curve2d, Double, Double, Double)  
Public method Set(Curve2d, Curve2d, Curve2d, Double, Double, Double)  
Public method Set(Point2d, Double, Double, Double, Vector2d, Boolean)  
Public method SetAngles  
Public method SetToComplement  
Top
See Also

©  Bricsys NV. All rights reserved.