Returns the matrix that rotates by angle about
the axis passing through the center.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static Matrix3d Rotation(
double angle,
Vector3d axis,
Point3d center
)
Public Shared Function Rotation (
angle As Double,
axis As Vector3d,
center As Point3d
) As Matrix3d
public:
static Matrix3d Rotation(
double angle,
Vector3d axis,
Point3d center
)
static member Rotation :
angle : float *
axis : Vector3d *
center : Point3d -> Matrix3d
Parameters
- angle Double
- [in] Rotation angle.
- axis Vector3d
- [in] Rotation axis.
- center Point3d
- [in] Center of rotation.
Return Value
Matrix3d
See Also