AttributeCollection Class

Provides a container for block reference attributes.
Inheritance Hierarchy
SystemObject
  Teigha.DatabaseServicesAttributeCollection

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class AttributeCollection : ICollection, 
        IEnumerable

The AttributeCollection type exposes the following members.

Properties
  Name Description
Public property Count Gets the number of elements in the collection.
Public property Item Gets the item by its index in the collection.
Top
Methods
  Name Description
Public method AppendAttribute Appends the specified attribute to the block reference.
Public method CopyTo Copies the entire collection to the array starting at the specified index.
Public method GetEnumerator Returns an enumerator object for the collection.
Top
See Also

©  Bricsys NV. All rights reserved.