mech:compdef-get-allcustompropertiesvalues


(mech:compdef-get-allcustompropertiesvalues  blkRefOrSolid)

Returns the list of property values for the specified blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

Return

list of value definitions on success, or NIL if no Categories/PropertySets are assigned

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 49c5d510>

(setq res (mech:compdef-get-allcustompropertiesvalues blkRefOrSolid))
(("Test" "TestProp" "zzz" "zzz"))

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

structure of a value definition
(PropertySet PropertyName Value ValueAsString)



©  Bricsys NV. All rights reserved.