mech:compdef-get-block


(mech:compdef-get-block  blkRefOrSolid)

Returns the BlockDefinition or 3dSolid object to which the blkRefOrSolid (ename) entity is attached to.

Arguments

blkRefOrSolid (ename) the entity to query

Return

ename on success, or NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 49c5d510>
(setq res (mech:compdef-get-block blkRefOrSolid))
<Entity name: 49c5d310>

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note




©  Bricsys NV. All rights reserved.