mech:compdef-get-componenttype


(mech:compdef-get-componenttype  blkRefOrSolid)

Returns the Component type of the blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

Return

type of the Component (integer) on success, or NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b19a0>

(setq res (mech:compdef-get-bomstatus blkRefOrSolid))
0
(setq res (mech:compdef-get-componenttype blkRefOrSolid))
2

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

the returned integer value is one of the Component Type values



©  Bricsys NV. All rights reserved.