mech:compdef-get-custompropertyvalue


(mech:compdef-get-custompropertyvalue  blkRefOrSolid  category  property)

Returns the actual Property value for the specified property in category (PropertySet) of the blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

category (string) the Catgory/PropertySet name to query

property (string) the name of the Property to query

Return

single "property value definition" list on success, or NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b19a0>
(setq res (mech:compdef-get-custompropertyvalue blkRefOrSolid "Test" "TestProp"))
("Test" "TestProp" "zzz" "zzz")

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

structure of a value definition
(PropertySet PropertyName Value ValueAsString)



©  Bricsys NV. All rights reserved.