mech:compdef-get-instances


(mech:compdef-get-instances  blkRefOrSolid)

Returns the list of entities, which are instances of the component referenced by blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

Return

list of entities on success, or NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b3440>
(setq res (mech:compdef-get-instances blkRefOrSolid))
(<Entity name: 400b3680>)

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

returned list is non-empty only if the component type is 'Assembly'



©  Bricsys NV. All rights reserved.