mech:compdef-get-filestatus


(mech:compdef-get-filestatus  blkRefOrSolid)

Returns the actual file status for the (external) component referenced by blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

Return

file status (integer) on success, or NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b19a0>
(setq res (mech:compdef-get-filestatus blkRefOrSolid))
1

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

the returned integer status is one of the Component FileStatus values



©  Bricsys NV. All rights reserved.