mech:compdef-get-standard


(mech:compdef-get-standard  blkRefOrSolid  localisedName)

Returns the name of the standard of the component, referenced by the blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

localisedName  T/NIL  defines whether the localised (T) or the global (NIL) English standard name shall be returned

Return

global resp. localised name of the standard (string), or NIL if not a "standard part" (and in case of an error)

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))

<Entity name: 7dabeda0>
(setq res (mech:compdef-get-standard blkRefOrSolid NIL))
"ANSI"

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

see function (mech:compdef-get-isstandard)



©  Bricsys NV. All rights reserved.