mech:compdef-get-physicalmaterial


(mech:compdef-get-physicalmaterial  blkRefOrSolid)

Returns the name of the material assigned to the component, referenced by the blkRefOrSolid (ename) entity.

Arguments

blkRefOrSolid (ename) the entity to query

Return

name (string) of the assigned material, or NIL in case of an error

Example

(vl-load-mech)  1
(setq blkRefOrSolid (entlast))
<Entity name: 400b3440>
(setq res (mech:compdef-get-physicalmaterial blkRefOrSolid))
""

Remarks

blkRefOrSolid could be a BlockReference or 3dSolid

Note

material name can be an empty string



©  Bricsys NV. All rights reserved.