mech:get-componentparametervalue


(mech:get-componentparametervalue  idBlockRef  paramName)

Returns the (double) value of parameter paramName (string) of the constrained idBlockRef BlockReference entity (ename); returns a double or NIL.

Arguments

idBlockRef (ename) the BlockReference entity to be queried

paramName (string) the parameter name to query for its 'parameter value'

Return

the double value if the parameter is a numerical value, or evaluates to a numerical value; otherwise NIL is not appropriate

Example

(vl-load-mech)  2
(setq ent (car (entsel)))  <Entity name: a411e960>
(mech:get-componentparameterisstring ent "Size")  T
(mech:get-componentparametervalue ent "Size")  NIL
(mech:get-componentparameterstringvalue ent "Size")  ".375-24 UNF"  <<==

Remarks


Note




©  Bricsys NV. All rights reserved.