mech:get-componentparameterisstring


(mech:get-componentparameterisstring  idBlockRef  paramName)

Returns whether the parameter paramName (string) of the constrained idBlockRef BlockReference entity (ename) uses a string/expression or a numeric value.

Arguments

idBlockRef (ename) the BlockReference entity to be queried

paramName (string) the parameter name to query

Return

T if the parameter provides a string value; NIL if the parameter provides a double value

Example

(vl-load-mech)  2
(setq ent (car (entsel)))  <Entity name: a411e960>
(setq res (mech:get-componentparameterisstring ent "Size"))  T

Remarks


Note




©  Bricsys NV. All rights reserved.