mech:get-effectiveblockrefname


(mech:get-effectiveblockrefname  idBlockRef)

Returns the effective BlockReference name of the constrained idBlockRef (ename) as shown in Mechanical Browser.

Arguments

idBlockRef (ename) the BlockReference entity to be queried

Return

'effective block name' as string, or NIL

Example

(vl-load-mech)  2
(setq ent (car (entsel)))  <Entity name: aea609f0>
(mech:get-effectiveblockrefname ent)  "box_3dist_3param"

Remarks

BlockReferences with constraints could be changed from named BlockTableRecord to an anonymous clone of the BlockTableRecord

Note




©  Bricsys NV. All rights reserved.