mech:get-componentparameterstringvalue


(mech:get-componentparameterstringvalue  idBlockRef  paramName)

Returns the parameter string or parameter expression of the parameter paramName (string) of the constrained idBlockRef BlockReference entity (ename).

Arguments

idBlockRef (ename) the BlockReference entity to be queried

paramName (string) the parameter name to query

Return


Example

(vl-load-mech)  2
(setq ent (car (entsel)))  <Entity name: a411e960>
(mech:get-componentparameterisstring ent "Size")  T
(mech:get-componentparameterstringvalue ent "Size")  ".375-24 UNF"

Remarks

see function (mech:get-componentparameterisstring)

Note




©  Bricsys NV. All rights reserved.