mech:instance-get-definitionid


(mech:instance-get-definitionid  idEnt)

Returns the ename of the definition BlockTableRecord for the specified idEnt (ename) component instance.

Arguments

idEnt (ename) the entity

Return

BlockTableRecord (ename) with the InstanceDefinition, or NIL

Example

(vl-load-mech)  2
(setq blkRef (car (entsel)))  <Entity name: 7c8dea10>
(setq res (mech:instance-get-definitionid blkRef))  <Entity name: 49f91130>

Remarks

the idEnt entity could be a BlockReference or 3dSolid

Note




©  Bricsys NV. All rights reserved.