mech:instance-get-entityid


(mech:instance-get-entityid  idEnt)

Returns the ename of the referenced entity for the specified idEnt (ename) component instance.

Arguments

idEnt (ename) the entity

Return

the entity referenced by this ComponentInstance (ename), or NIL
(could be a BlockReference or 3dSolid)

Example

(vl-load-mech)  2
(setq blkRef (car (entsel)))  <Entity name: 49f913b0>
(setq res (mech:instance-get-entityid blkRef))  <Entity name: 49f913b0>

Remarks

the idEnt entity could be a BlockReference or 3dSolid

Note




©  Bricsys NV. All rights reserved.