(setenv variable value)
Set the operating system variable to that value.
This function sets the value of a specified operating
system environment variable-for example, as stored by the
DOS PATH variable.
NOTES
- If you give setenv a non-existent variable name, it creates
that, and sets it. You can see the new variable name from within
Bricscad's "shell" DOS window (created by the Shell command)
but not from the Windows DOS window. Setenv creates the variable within
Bricscad's application space.
- When you enter ICAD or ACAD as
the environment variable you want to set, the setenv function changes that to
the SEARCHPATH variable and uses it normally.
Example
Code |
Returns |
(setenv
"PATH" "C:\\;C:\\WIN95;C:\\ICAD") |
"C:\\;C:\\WIN95;C:\\ICAD" |
Tell me about...
(getenv
variable)
(setcfg
parameter value)
(setvar
sysvar value)
LISP
Compatibility
Programming
Overview of LISP (LISt Processing) Language
Bricscad™ is commercialized by Bricsys NV. Bricsys NV and Vondle NV
are fully owned subsidiaries of Menhirs NV. © 2001- Menhirs NV - All rights reserved. |