bim:list-properties


(bim:list-properties  ename)

Returns a list of all properties (list of strings) available for the specified entity, if the entity is classified as a BIM Element

Arguments

ename  the entity to query, as normal entity or as VLA object name

Return

list of property names (list of strings)

Example

(bim:set-bimtype ent "Wall")  T
(bim:list-properties ent)

("AcousticRating" "Combustible" "Compartmentation" "Composition" "Description" "ExtendToStructure" "FireRating" "IsExternal" "LoadBearing" "Name" "Reference" "RoomBounding" "SpatialLocation" "SurfaceSpreadOfFlame" "ThermalTransmittance" "WallType")

Remarks

see (bim:list-propertiesmap), (bim:get-property), (bim:set-bimtype), (bim::set-assigned-building) and (bim::set-assigned-story)
all property names are always case-sensitive !



©  Bricsys NV. All rights reserved.