bim:list-propertiesmap


(bim:list-propertiesmap  ename)

Returns a list of all properties with their property categories (list of dotted-pairs) available for the specified entity, if the entity is classified as a BIM Element

Arguments

ename  the entity to query, as normal entity or as VLA object name

Return

list of dotted-pairs, listing the property names with their BIM category

Example

(bim:set-bimtype ent "Wall")  T
(bim:list-propertiesmap ent)

(("AcousticRating" . "IFC2x3") ... ("Composition" . "Bricsys") ... ("GrossSideArea" . "BricsysQuantity") ... ("NL/SfB Classification" . "Classification System"))

Remarks

see (bim:list-properties), (bim:get-property), (bim:set-bimtype), (bim::set-assigned-building) and (bim::set-assigned-story)
all property names are always case-sensitive !



©  Bricsys NV. All rights reserved.