AssocArrayCreateArray Method
|
Creates an associative array with the
specified source entities, base point and parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public static AssocArray CreateArray(
ObjectIdCollection sourceEntities,
VertexRef basePoint,
AssocArrayParameters parameters
)
Public Shared Function CreateArray (
sourceEntities As ObjectIdCollection,
basePoint As VertexRef,
parameters As AssocArrayParameters
) As AssocArray
public:
static AssocArray^ CreateArray(
ObjectIdCollection^ sourceEntities,
VertexRef^ basePoint,
AssocArrayParameters^ parameters
)
static member CreateArray :
sourceEntities : ObjectIdCollection *
basePoint : VertexRef *
parameters : AssocArrayParameters -> AssocArray
Parameters
- sourceEntities
- Type: Teigha.DatabaseServicesObjectIdCollection
[in] Identifiers of source entities.
- basePoint
- Type: Teigha.DatabaseServicesVertexRef
[in] Base point that is relative to the source entities.
- parameters
- Type: Teigha.DatabaseServicesAssocArrayParameters
[in] Parameters for the array.
Return Value
Type:
AssocArray
The created associative array.
See Also