VertexRef Class

This .NET class wraps the OdDbVertexRef class.

This class represents a reference to a vertex.

Inheritance Hierarchy
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public class VertexRef : SubentRef

The VertexRef type exposes the following members.

Constructors
  Name Description
Public method VertexRef
Default constructor for the VertexRef class. Creates an object that wraps a corresponding C++ OdDbVertexRef object.
Public method VertexRef(CompoundObjectId)
Constructor for the VertexRef class. Creates a vertex reference to an object specified by the full sub-entity path.
Public method VertexRef(Entity)
Constructor for the VertexRef class. Creates a vertex reference to a specified entity.
Public method VertexRef(FullSubentityPath)
Constructor for the VertexRef class. Creates a vertex reference to an object specified by the full sub-entity path.
Public method VertexRef(Point3d)
Copy constructor for the VertexRef class. Creates a vertex reference to a specified point.
Public method VertexRef(CompoundObjectId, SubentityId)
Constructor for the VertexRef class. Creates a vertex reference based on the specified compound object.
Public method VertexRef(CompoundObjectId, SubentityId, Point3d)
Constructor for the VertexRef class. Creates a vertex reference based on the specified compound object.
Top
Properties
  Name Description
Public property Point
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.